Installed Browser Extensions (Hunt Extension Name)
This query will output a table with all installed browser extensions.
EDRhunting
FDR intermediatepor CrowdStrike (cql-hub.com) 1 min read
Query
// Get browser extension event
#event_simpleName=InstalledBrowserExtension BrowserExtensionId!="no-extension-available"
// Look for string "vpn" in extension name
| BrowserExtensionName=/vpn/i
// Make a new field that includes the extension ID and Name
| Extension:=format(format="%s (%s)", field=[BrowserExtensionId, BrowserExtensionName])
// Aggregate by endpoint and browser profile
| groupBy([event_platform, aid, ComputerName, UserName, BrowserProfileId, BrowserName], function=([collect([Extension])]))
// Get unnecessary field
| drop([_count])
// Convert browser name from decimal to human readable
| case{
BrowserName="3" | BrowserName:="Chrome";
BrowserName="4" | BrowserName:="Edge";
*;
}Explicación
Importado desde cql-hub.com. Agrega explicación de pipes aquí.
Variables a ajustar
Revisa y ajusta los valores según tu entorno.